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8 MORE ON DATABASE USE 
Manipulating the Data in the Database 

 

LEARNING OUTCOMES 
Lesson 6 introduced you to the database concept in general, and to the Access database in 
particular. You learned how to plan a new database, how to set it up, how to add records, make 
changes to records, and delete records. You also learned how to save a database, and how to make 
backup copies. 

It is now time to start using those functions of the database that make it such a powerful tool 
for learning—for organizing data resulting from research, for helping you or your students to work 
on projects, for personalizing your interaction with students, and so forth. Some of the exercises 
cover aspects of database use—rules for finding and sorting records, for example—which may be 
difficult for you to grasp. Forewarned is forearmed; put your thinking cap on! 

Lesson 8, then, after reviewing the basics, will introduce you to the following additional 
features of the Access database: 

• searching and querying a database 

• sorting records 
• creating reports 

• improving the report (making changes) 
• printing reports 

A caveat before you begin: You'll find it easiest to use the tutorial if you follow the directions 
carefully. On computers there are always other ways of doing things, but if you wander off on your 
own be sure you know your way back! 

 

8.1 GETTING STARTED 
What are the some of the advantages that electronic databases have over manual record keeping 
systems such as filing cabinets, folders, rolodexes, and the like? By the time you completed Lesson 
6 you must have had a clearer idea of what a database is, and can probably now come up with an 
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answer to this question. Here are a couple of the reasons frequently forwarded for using a database. 
Can you find your response among them? 

• One can store huge amounts of data in a small amount of space (on a 2013 generation 
USB/flash drive or, even better, a hard disk—not to begin to mention the so-called 
Cloud1— you can store millions of database records); 

• One can easily manage all the data—view records, add new records, delete old records, or 
change existing records. 

You learned how to handle tasks such as these in Lesson 6. Here are some other reasons for using 
an electronic database. 

• One can quickly find anything one needs to know, and get answers to questions about the 
data in the database. What is Larry Dorey’s phone number? 

• One can home in on a small subset of the data. Which students have a GPA below 2.0? 

• One can instruct the computer to arrange (sort) records, and thus organize the data any way 
one likes. I'd like a listing with everything sorted based on the student hobby field. That'll 
make it easy for me to identify students who have the same interests. 

• One can use the computer to create any number of reports for the purpose of supplying others 
with information pertaining to the data in the database. My principal, Yvonne Singer, wants 
a monthly report of student progress in Reading, Writing, Math and Science. 

The purpose of this tutorial is to help you learn how to use the Access database in these last four 
ways. By the end of the tutorial you will have the basic skills you need to become a power user of 
the database. Whether you ever can call yourself a skilled user will depend, of course, on whether 
or not you continue to use Access as a tool to support your professional work in the classroom. 
Practice makes perfect. If, after you complete this lesson, you never use a database again… Well, 
let’s not go there, OK? 

Make sure you have your Work Files for Office 2013 available on your 
computer, then open Access (Start > All Programs > Microsoft Office > 
Access 2013) 

From the File menu select Open. 

Access will display the Open dialog box. 

In the Backstage View, navigate to your USB Drive > Work Files for Office 
2013 > Access Files folder 

You are going to work first with a database similar to the one you created in Lesson 6. The 
database, called Students 2013, has been prepared for you to use with this tutorial in order to 
standardize the directions that follow. 
                                                
1 The Cloud, as it’s called, is a virtual place which companies such as Apple and Microsoft (to name but two) have 
configured in such a way that it can handle massive—as in humongous—amounts of data that are actually stored on 
a large number of computers connected through a real-time communication network such as the Internet.  You don’t 
need to think about where your data is; you just use the Cloud to store copies of your data somewhere safe and off 
your own computer. 
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In the Access Files folder open the Students 2013 database (NOT the 
Student Roster 2013 database), then, in response to the SECURITY 
WARNING, click on the Enable Content button 
On the left frame of the Access window, click on the down arrow to bring up 
the pull down menu of database objects (Fig. 8.1) 

  
Fig. 8.1 Selecting a Form or a Table 

Make sure the Forms object is selected (Fig. 8.1), then double click to open 
the Student Records Form 

You should see the Forms View of the Students 2013 database, as illustrated in Fig. 8.2. 

 
Fig. 8.2 The Forms View of the Students 2013 database 

Click here to 
pull down 
the Access 

Objects 
menu 
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8.2 REVIEWING THE BASICS 
You may not have worked with databases a great deal prior to using these tutorials, so it will be a 
good idea to start by recapitulating what you learned in Lesson 6 by way of reinforcement. Then 
you can move on to learn about the new features of the Access database that are targeted for this 
tutorial. Let's start with terminology. 

A database is a document which contains a set of records. Each record is made up of one or 
more fields, and each field may or may not contain entries. 

For example, a database of movie titles might have records for a few thousand movies. Each 
record will have fields for the movie title, the director, the producer, the star(s), and so on. A 
particular entry for the Movie Title field might be "Star Wars." 

Viewing the data in the database 
When you first open an existing database into primary memory, it is generally best to open a Forms 
View of the database because you can easily view the contents of an entire record on the screen, 
thus showing you what all the records basically contain. 

In the Forms View, as you can see, the data for one complete record is shown in the Form. 
Notice the database navigation tools at the bottom of the Form window (Fig. 8.3). 

 

 
Fig. 8.3 Navigation tools in the Access database 

Look them over now to re-familiarize yourself with how they work. 
Now, close (ctrl-F4) the Student Records Form and, in the left frame of the 
database window, in the Objects menu, switch to Tables, and double click 
on Student Records Table to open it 

This Datasheet view (Fig. 8.4) shows the records across the screen in rows and columns much like 
the Spreadsheets you learned to use in Lessons 4 and 5. 

 
Fig. 8.4 Viewing records in the Datasheet view 
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Adding a record to the database 
You can add a new record any time you want, wherever you may be in the database, because you 
can tell Access to sort everything into a specific order whenever you need to do so. You will learn 
how to do this in a later section of this tutorial (8.4 SORTING RECORDS). You are going to add 
a couple of new records now. It’s easiest to do this in the Forms view of the database. 

Close (ctrl-F4) the Student Records Table, in the Objects menu (left frame of 
the database window) select Forms, and double click on Student Records 
Form 
In the Home Ribbon > Records Group, click on the New button (Fig. 8.5) 

 
Fig. 8.5 The New button in the Records Group of the Home Ribbon 

This will open up a set of empty fields for the new record (Fig. 8.6) 

 
Fig. 8.6 Entering data for a new record 

Enter the data for this new record, then add data for at least one other new 
record (two records in all), pressing the Tab key after you type the data for 
each field 
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You can put any data in the new records you are adding because you’ll delete them in a bit. You 
can even skip a field, if no data is required for that field, by simply pressing Tab without entering 
any data. 

Clearing a field in a record 
First you need to know that you cannot clear entries from a field that has been defined as requiring 
data of some kind in the field. If you try to clear data from these fields (in our database the First 
Name through the Home Contact fields, for example) you will get a warning prompt from Access 
telling you that you cannot have a null value in these fields. 

Use the navigation tools (see Fig. 8.3 on page 257) to go back to the first of 
the records you added just now 
In the first of the records you added just now, in the Nick Name field, double 
click in the entry box (not on the field name) to highlight the data in the Nick 
Name, then in the Home Ribbon > Clipboard Group select Cut (ctrl-X) 
Next go to the second of the records you added a moment ago, click in the 
Clubs field entry box and again select the data in the Clubs field, then in the 
Home Ribbon > Clipboard Group select Cut (ctrl-X) 

Notice that this does not delete the field or the record; it simply clears the selected data in the field. 
The field is still there, so new data can be entered into it at any time. 

Deleting (clearing) a record, or a set of records 
Locate one of the records you just added, then in the Home Ribbon > Records 
Group > Delete menu (Fig. 8.7), select Delete Record 

 
Fig. 8.7 Deleting a Record 

Access immediately displays a warning dialog box (Fig. 8.8) to tell you that if you go ahead you 
will permanently lose the data in the record. 

 
Fig. 8.8 Delete Record warning prompt 

Click on Yes to delete the selected record 
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Notice that this removes the record entirely. 

Changing the data in a field 
Suppose some data gets entered incorrectly—through misspelling or a typo. Let's say you needed 
to update a nickname in a student's record. To change it you would do the following. 

Locate the record in which you want to make the change (for this exercise 
select any record you like) 
Click in the entry box for the field name that needs to be changed (use any 
entry in the Nick Name field), then change it to some other nick name in the 
same way you would in a word processor 

All of the exercises in this section were by way of recapitulating what you learned in Lesson 6. 
Now let’s move on to learn some more advanced features of the Access database. 

 

8.3 SEARCHING AND QUERYING A DATABASE 
This is a powerful function of the Access database. You can find anything in the database if you 
know what to do. 

All you have to do is give Access any set of characters as the key for a search of the database, 
and the system will find that set of characters, if it exists, even if it is just a part (a subset) of a 
larger word or phrase. There are several ways you can do this. But first you need to open another, 
larger, database onto the Access Desktop. 

Close the Students 2013 database document and from the File menu select 
Open 

Your USB drive containing your Work Files for Office 2013 should still be in a USB port on your 
computer. 

On your USB drive > Work Files for Office 2013 > Access Files folder open 
the Birds database, then, in the drop down Objects menu on the left side of 
the database window, open the BirdSightings Form (Fig. 8.9) 

 
Fig. 8.9 Bird Sightings Form 
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Finding a single record using data from a specific field 
You often may need to locate and display the contents of one particular record, or set of records, 
based on data from one specific field. The Find function, which is in the Home Ribbon > Find 
Group, is the Access command to do this. It works much the same as when you use the Find 
command in the word processor, which you learned about in Lesson 2. 

Suppose, for example, you wanted to find the record for the bird with the Common Name 
Northern Oriole. Here is how you do this. 

In the Home Ribbon > Find Group click on the Find button (Fig. 8.10) 

  

Fig. 8.10 The Find button 
Access now displays the Find and Replace dialog box (Fig. 8.11) 

  

Fig. 8.11 The Find and Replace dialog box 
You need to indicate what data you want found in the database by first typing in the search string 
(Northern Oriole). 

In the Find What: entry box type Northern Oriole (or northern oriole—if you 
don’t check the “Match Case” box, Access doesn't care whether you use upper 
or lower case letters) 
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Before clicking on the Find Next button, you need to identify what part of the database you want 
Access to “Look In.” You also need to indicate if you want to match the data in a Whole Field or 
Any Part of a Field. 

Click on the arrow to pull down the Look In: options and select Current 
document, then click on the arrow next to the Match: options and, from the 
drop down menu, select Any Part of Field 
Now click on Find Next, then click on Cancel 

The record(s) you find with a Find request are called the "found set". As you see, Access quickly 
locates the record containing the name "Northern Oriole." This one record alone is shown in the 
BirdSightings Form window. Of course, if you typed Northern Oriole incorrectly, Access would 
tell you that the search item was not found (Fig. 8.12). 

 
Fig. 8.12 Warning message after unsuccessful search of the database 

Close the Find and Replace dialog box, then in the Home Ribbon > Views 
menu, select Datasheet View to see the records following the Northern Oriole 
record 

Finding two or more records based on data from a single field 
Next, let’s search on criteria which will find more than one record. You want to find any bird with 
the primary color (Color1) that has any shade of black in its plumage. 

Close (ctrl-F4 or X out of) the BirdSightings datasheet table 
Double click on the BirdSightings Form to open it, and click to put the cursor 
anywhere in the Color1 field 
Click on the Find button in the Home Ribbon’s Find Group (looks like a pair of 
binoculars), type the word Black in the Find What: box, in the Look In: box 
select the option for Current Field, and in the Match: box select the option for 
Any Part of Field 
Click on Find Next, then move the Find and Replace dialog box out of the 
way, if necessary, so you can see the contents of the record  

The search finds the first of 11 records where a bird in the database has the color “black” or even 
“blackish” in its plumage. 

To see the data in the next record, click on Find Next again, and so on 
See if you can count 11 records of birds with the color black or blackish in 
the plumage? 

To see a listing of all the records that result from a search such as this, you must use a filter. 
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Filter by selection 
The exercise that follows will use a filter to select the set of birds whose habitat is “marshes.” This 
is best done in the Tables View of the database. 

Close (ctrl-F4 or x out of) the BirdSightings Form and, in the All Access 
Objects menu (Fig. 8.13), double click on the BirdSightings Table 

 
Fig. 8.13 The BirdSightings Table 

In the datasheet table, scroll to the right to locate the Habitat column 
Now (and this is tricky, so stay focused) position the mouse arrow near the 
left edge of one of the marshes entries until the mouse pointer will become 
a hollowed-out plus sign (     )—and, when it does, click the mouse 
button 

This tells Access that you want to filter by selection the set of birds which lives among marshes. 

In the Home Ribbon > Sort & Filter Group, click on the Filter by Selection 
icon (Fig. 8.14) and, in the menu that pops up, select Equals “Marshes” 

  
Fig. 8.14 Filter by Selection icon in the Sort & Filter Group 

Filter by 
Selection icon 
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Access now displays a list of 15 birds in the database that live in marshes (Fig. 8.15). 

 
Fig. 8.15 The found set of filtered records 

To go back to viewing all the records in the database, click the Toggle Filter 
icon on the toolbar (Fig. 8.16)  

 
Fig. 8.16 Toggle Filter icon in the Sort & Filter Group 

Toggle Filter 
icon in the 

Sort & Filter 
Group 
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Filter by Form 
You also can filter records using a Form. In other words, you can select a set of records no matter 
what database mode you are in—a Table or a Form. Here’s how you do a Filter by Form. 

Let’s say you want to find all the records in which the birds have either the color “black” or a 
combination of “black” and some other color in their plumage. 

In the Home Ribbon > Sort & Filter Group, click on the Advanced Filter 
Options icon and, in the drop down menu, select Filter by Form (Fig. 8.17) 

 
Fig. 8.17 Access Advanced Filter Options 

Access presents an empty record for you to select the criteria for the filter (Fig. 8.18). 

  
Fig. 8.18 The Filter by Form window with its Look For and Or tabs 

Advanced 
Filter Options  

Filter by 
Form option 
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Notice that Access keeps previous search criteria (“marshes” from our previous search) active 
unless you remove them from the filter. So you need to tell Access that the previous filter (for the 
birds that live among marshes) is no longer relevant. This is easy enough to do. 

Drag to highlight the “marshes” habitat, if it isn’t already highlighted, and hit 
the Backspace key 

Now you are going to do a Filter by Form using the Color1 field. You want to find all the birds 
that have either black, or any variation on black, such as blackish green or blackish blue, in their 
plumage. 

To do this, first click in the data entry area below the column header of the 
Color1 field 

You should now see a small down arrow at the right hand edge of the Color1 data entry box (Fig. 
8.19). 

Click on this down arrow on the right edge of the Color1 data entry box to 
see a list of all the possible colors in the Color1 field of the Birds database (Fig. 
8.19) 

 
Fig. 8.19 The drop down list of color1 colors 

Click on the color “black” in the list, then click on the first Or in the Look for 
filter rule icons at the bottom of the Filter by Form dialog box (Fig. 8.19 above) 

Click on this 
arrow to pull down 
the Color1 options 

Look for filter 
icons 



Lesson 8: More on database use 

 285  

This will bring up a new, empty filter dialog box. 
In the Color1 field, click again on the down arrow to see the list of possible 
Color1 colors and, in the drop down list, click on “blackish green” 
Now, click on the next Or in the Look for filter icons at the lower left of the 
Form, then, once more, click on the arrow on the right edge of the Color1 
data entry box to bring up the full list of possible Color1 colors 
This time, in the drop down list of possible colors, click on “bluish black” 

That is all the colors in the Color1 field that have the color black in them. 

Now, in the Home Ribbon > Sort & Filter Group, click on the Toggle Filter 
button (Fig. 8.20) 

 
Fig. 8.20 The Toggle Filter button 

Immediately Access filters out the set of birds (11 records in all) with some kind of black in their 
plumage (Fig. 8.21). 

 
Fig. 8.21 The result of the color filter 

Searching based on criteria from more than one field 
This time you are going to give Access two or more search criteria for your search of the database. 
The system will search every field of every record, locating only those records that contain the set 
of characters that make up the search criteria. Access will then display the complete contents of all 
the records that contain the data you’re looking for. 

Toggle 
(Apply) 

Filter tool 
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It doesn't matter where you are in the database to begin the search. Access will always search the 
entire database for the records you request. 

For instance, let's say you want to find all the records for birds that you spotted in the month 
of September. You know there were several, but you don't remember which they were. Here are 
the steps you would take to do this. 

First you need to remove any filters from a previous search; this is because Access remembers 
them from search to search. 

In the Home Ribbon > Sort & Filter Group, click on the Toggle Filter icon 
(Fig. 8.22) 

 
Fig. 8.22 Toggle Filter icon in the Sort & Filter Group 

Now, in the Home Ribbon > Sort & Filter Group click on the Advanced Filter 
Options icon and, in the drop down menu, select Filter by Form 

This gives you the opportunity to remove any earlier filters you may have used. 

Remove the “black” filter in the Color1 box by hitting the Backspace key 
Now click on the first Or tab in the filter search (Look for) tools at the bottom 
left of the window, and hit the Backspace key to remove the criterion “blackish 
green” 
Finally, click on the next Or tab, and hit the Backspace key to remove “bluish 
black” 

Now that you have removed any old filters, you are ready to create the new filter. 
First, in the Filter by Form window, click on the Look for tab in the lower left 
corner, then scroll across if necessary to locate the Date Sighted data entry 
box (the data entry box is immediately below the field name at the top of the 
column), and click in the data entry box to put the cursor there 

Toggle Filter icon 
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Click on the down arrow on the right side of the data entry box in order to see 
the drop down list of all Dates on which birds were Sighted 
Click on the first date which has a ‘9’ for the month (September) 

After you click on it, you’ll see the first date in the entry box with the ‘#’ symbol to indicate its 
selection by the filter. 

Click on the first Or tab, then click on the arrow in the Date Sighted box again 
and select the second date with a ‘9’ for the month 
Now click on the Toggle Filter button in the toolbar 

Access quickly finds the set of records for birds sighted on the 1st or 8th of September. How many 
records did you get? There should be 12. 

This might seem to you like a silly exercise. Maybe it wouldn’t take you long to find the 12 
records out of the 50 records in the database. Wouldn’t take you a minute or two to do that, right? 
But suppose you have 500 records, or 5000 records, or, as is common in school districts in large 
cities, 500,000 records or more. The larger the database, the more you need tools such as these 
filter tools—and the Sort tools in the next section—to help you quickly find the data you need. 

 

8.4 SORTING RECORDS 
The three major advantages of an electronic, digital data storage system over a manual, paper-
based filing system are these: 

1. Digital, electronically stored data, with its easy ability to quickly access the data you need 
in any of multiple formats and the easy ability to organize it in any of multiple ways, 
provides more or less instant organizational flexibility, which helps you cope with the 
inevitable complexity that increases as the sheer amount of data grows. 

2. Digital, electronically stored data saves space—physical space, that is. You don’t need a 
filing cabinet, or oodles of filing cabinets in a storage room, or, for some companies, a 
whole building for a data repository.  For teachers, like you and me, all we need is a few 
gigabytes of storage on a USB drive, which we can carry on a car key chain or in a pocket 
(provided we’re careful to backup all the data on another computer in the office or at home). 

3. Digital, electronically stored data increases the speed of data access and thus saves time. 

When we use old-fashioned filing cabinets to store data, we usually come up with some kind of 
organization. So we put labels on the drawers in the cabinets and labels on the folders inside the 
drawers. This organization is often based on numeric or alphabetic sequencing. The purpose, of 
course, is to enable us to quickly find what we have stored in the appropriate folder in the 
appropriate drawer. 

This is a good system as long as we have no cause to frequently change the organization we 
have set up. It also assumes that space and time are not at a premium in our day to day operations. 
Unfortunately, coping with change, making good use of space, and saving time are factors critical 
to our productivity. So we should welcome any system which helps us cope with change and 
optimizes our use of space and time. 

Today, using state of the art technology, we can electronically store the equivalent of the 
Library of Congress in a shoe box. And we can now access any specific item in that "box" in a few 
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thousandths of a second. What is more, software such as Access makes it possible for you to 
organize that data more or less on the fly by sorting it any which way you want. 

Sorting on a single field 
Take, for example, the Birds database that is on your Desktop at this time. As you can see, the bird 
names (Common Name field) are not sorted in any particular order. In fact, the database is sorted 
based on the Date on which each bird was Sighted. 

Take a look at the Date Sighted field now and notice that it is, in fact, sorted 
from the earliest date (9/1/1993) to the latest date (5/21/1997) 

So the ordering is chronological rather than alphabetical. It would therefore be time consuming, if 
not impossible—especially if the database were very large—for you to visually scan the database 
to find the record for a particular bird. 

This is why Access makes available the Go To Record, Sort Records and Match Records 
functions under the Organize menu. 

What if you wanted to print out a report listing all the birds in alphabetical order by name of 
bird? You would have to begin by organizing the records alphabetically on the bird names. 
Fortunately Access has a Sort Records... function that enables you to complete this operation with 
the greatest of ease. 

First you need to remove the filter you used to select the set of birds sighted in September. 

In the Home Ribbon > Sort & Filter Group click on the Toggle Filter tool 
(which right now should indicate that it will Remove an existing Filter, but if you 
don’t see ALL 50 of the records in the Birds database then click on Toggle 
Filter again)  

You can best see the results of a sort if you are in the Datasheet (Table) view of the database, 
which is the view you should have on your screen. 

If you do not have the Datasheet View, select it now from the Views Group > 
View menu > Datasheet View before proceeding 
Click to put the cursor anywhere in the Common Name field, then, in the Home 
Ribbon > Sort & Filter Group click on the Sort Ascending button (Fig. 8.23) 

  
Fig. 8.23 The Access Sorting tools 

Sort Ascending Tool 
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Immediately Access sorts the records alphabetically on the Common Name field. There are other 
sorting options depending on the type of data in the field you are using as the basis, or key, for the 
sort: 

• If your sort request is based on a Text field such as Common Name or Location Sighted, the 
sort can be either Ascending (A to Z) or Descending (Z to A). 

• If you are sorting on a Number field such as the Count field, you again would be able to sort 
in Ascending (Low number to high number) or Descending (High number to low number) 
order. 

• Finally, if you are sorting on a Date field such as Date Sighted, you would be able to sort in 
Ascending (Chronological) or Descending (Reverse Chronological) order.  

 
8.5 CREATING REPORTS 
A word about the Access database reporting facility 
Reports are what we submit to our bosses in response to information that they need. It doesn’t 
matter to anyone why they need the report. All that matters is that they must have it. So we 
(teachers and others in the chain of command) must produce it. Period. 

Access makes it easy to produce reports provided you have gathered any and all information 
needed for a report into a database.  Let us assume that you have done that. What, then, are the 
criteria for a good report? 

• Planning is still an important prerequisite for creating good reports. No matter how tempting 
it might be, always resist creating a report without first thinking and mapping out what you 
want as the finished version of a report. 

• Changes you make to data fields for the report do not affect the data in the database at all. 
So you don't have to worry about losing data, or messing up the database when you create 
reports. 

• You can create reports that contain just a few fields from a selected set of records by using 
the search criteria techniques that you already learned about in this lesson. For instance, you 
could use the Birds database to print a report listing just the name, color, and count of birds 
that were seen in your neighborhood. Shortly you will practice doing something along these 
lines. 

• You can create numerous layouts or reports based on the data in a database, each report 
having different sets of data, and you can store them all along with the database. 

In the next sections you will continue to work with the Birds database. You are going to create a 
simple report.  

Initial definition of the layout or report 
You are going to create a layout, or report format, which will list all members of the duck family 
sighted during the reporting period covered by the database. The fields in the report will include 
the Common Name, Family, Date Sighted and Count fields.  

Bear in mind that most databases have many fields. If there are more field names in a report 
layout than can fit across the screen or page, the names simply wrap around, creating two or more 
lines, if necessary, in the top section (the Header) of the layout. 

This can make for untidy, not to say confusing, reports. The columnar report you are about to 
work with will not have this problem because you will be using only a small selection of the fields 
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in the database (just 4 to be exact), but it is good to be aware of the problem should the occasion 
arise where you want to create a report that uses many fields.2 

You need to start by using a filter to create a new Table. You want to select only the birds in 
the Duck family for the Report. 

In the Home Ribbon > Sort & Filter Group click on the Advanced Filter 
Options tool, then select Filter by Form from the menu 
Just below the Family field name at the top of the column, click in the 
Family field entry box 
Now, click on the down arrow in the Family field entry box to see the drop 
down list of all possible families of birds, and click on Duck 
In the Home Ribbon > Sort & Filter Group click on the Toggle Filter (Apply 
Filter) button 

You should now see listed all the birds in the Duck family (there should be 9 of them), which are 
the records you want for the Report (Fig. 8.24). 

  
Fig. 8.24 The Report object in the database objects drop down list 

Next, click on the Create Tab to show the Create Ribbon at the top of the 
Access window and, in the Create Ribbon > Reports Group click on the 
Report Wizard tool (Fig. 8.24 above) 
A dialog box immediately pops up that asks you if you want to save the Table 
before you can close it and move on to create the report (a new object), so click 
on Yes 

                                                
2 You can get around this problem is various ways, the simplest of which is to change the font to one which requires 
less space, or reduce the size of the font you want to use, or consider whether you really need all the fields that you 
have selected for the report.  Often, simpler is better.  Simple reports are more likely to make the desired impact on 
the reader. 

Report Wizard Tool 
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This brings up the Report Wizard dialog box (Fig. 8.25). 

 
Fig. 8.25 The Report Wizard dialog box 

In the Tables/Queries data box, leave the default Table: BirdSightings table 
as the source for the report’s data 
Then, in the list of Available Fields: double click, one by one, on the 
Common Name, Family, Date Sighted, and Count fields, in order to move 
each of these four fields to the Selected Fields: box (Fig. 8.26) 

 
Fig. 8.26 Selecting the fields for the report 

Now click on the Next button 
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Access now asks you if you want to add any grouping levels to the report. 
You don’t want to add any grouping levels, so click on the Next button to by-
pass this dialog box 

In the next dialog box you are asked if you want to sort the records. There is no need to do this 
since you already sorted them in Ascending Order based on the Common Name. 

Click on Next once more to proceed to the next step in the Report Wizard 
The default setting for the report layout is Tabular, which is what you want. You are also going to 
print the report using Portrait Orientation, which, again, is the default setting. 

So make sure the radio buttons next to Tabular and Portrait Orientation are 
selected, then click on the Next button again 

In the next step of the Report Wizard you need to enter a new title for the report (Fig. 8.27). The 
default title is BirdSightings, but you want to make a more specific title to describe the contents of 
the Report. 

 
Fig. 8.27 Entering the title for the report 

For the Title of the report, type Count of Ducks Sighted, then click on the 
radio button next to “Modify the report’s design” (Fig. 8.27) 

You need to select the option to modify the report’s design because, as you will see shortly, you 
are going to rearrange the headers and fields so that they fit nicely on the page of the report. 

Finally, click on Finish  
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8.6 IMPROVING THE REPORT (MAKING CHANGES) 
The default design for the new report (Fig. 8.28), which you named Count of Ducks Sighted, needs 
some work. 

 
Fig. 8.28 The unmodified report in the Design View 

After completing the following exercises, the report layout in the Design View will look like that 
illustrated in Fig. 8.29. 

The Modify window (Design View) for the report has five sections to it: a Report Header 
section, a Page Header section, a Detail section (where the data will be listed), a Page Footer 
section and a Report Footer section. 

The Report Header section is where you have the Title for the report (Count of Ducks Sighted), 
which is usually a larger print than the body of the report and may also be centered at the top of 
the report. 

The Page Header section has the column headers for each of the columns in the columnar 
report and may also include the date. 

The Detail section is where the data for each record in the report are listed, and the Page Footer 
and Report Footer sections are for special items such as page numbers. 

  
Fig. 8.29 The modified report in the Design View 
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In the Page Header section, the space allowed for the Common Name field is fine, but the Family 
column is wider than necessary. Here are the steps for you to fix this. 

Click once on Family to select the box for the Family field 

Now grab the right edge of the box—the right edge, not the left—and drag the 
edge of the box to the left to reduce its width till it is a little more than the 
width of the word Family itself (see Fig. 8.29 on previous page) 

The Date Sighted Page Header and the Count header are fine as is, but they both need to be moved 
over to the left for the report. 

Click in the Date Sighted box, then grab the upper or lower border of the box 
and drag it over to the left till it is close to the Family box (see Fig. 8.29 on 
previous page) 

Do the same for the Count box to bring it close to the Date Sighted box (see 
Fig 8.29 again) 

Now you must do the same for the Family, Date Sighted, and Count fields in the Detail section of 
the report. 

Click once, in the Detail section of the report, on Family to select the box for 
the Family field 

Now grab the right edge of the box—the right edge, not the left—and drag the 
edge of the box to the left to reduce its width till it is a little more than the 
width of the word Family itself (see Fig. 8.29 on previous page) 

The Date Sighted and the Count fields in the Detail section of the report are fine as is, but they 
both need to be moved over to the left to match up with the titles above the columns. 

Click in the Date Sighted box, then grab the upper or lower border of the box 
and drag it over to the left till it is close to the Family box (see Fig. 8.29 on 
previous page) 

Do the same for the Count box to bring it close to the Date Sighted box (see 
Fig 8.29 again) 

Your last task is to center the report title. 

Click on the title Count of Ducks Sighted 

Position the mouse arrow on the lower or upper border of the box till the arrow 
changes to a crosshair icon, then drag the title to the right till it is centered 
over the columns of the report (see Fig. 8.29 above) 

Now you are ready to Print Preview the report. 
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From the View menu, select Print Preview, and check out how your report 
will look when you send it to the printer (Fig. 8.30 on the next page) 

 
Fig. 8.30 Final version of the Count of Ducks Sighted report 

When you later open the Birds.accdb database to check the report, you’ll need to click in the Sort 
& Filter Group on the Toggle Filter button. 

The Count of Ducks Sighted report should look similar to that illustrated in Fig. 8.30. If you 
need to go back and do further modifications to the report, just go back to the View menu in the 
Views Group of the Home Ribbon and select Design View. 

 

8.7 PRINTING REPORTS 
Once you have prepared the new report, it is a straightforward process to print the report. The 
command to do this is the same as you have used to print any other documents from within 
Microsoft Office, whether you have been working in Word Processing or the Spreadsheet. 

You should still be in the Print Preview window, so click on the Print button 
at the top left of the Print Preview window to print the Count of Ducks 
Sighted report 

Remove the report from the printer and take a closer look at its contents. Notice that the only 
records in the report are those relating to ducks in the Family field. These are just a small subset 
of records drawn from the larger Birds database.  

 

LOOKING BACK 
The Access database is a sophisticated tool for managing data. The key to success, as in so many 
activities, is PLANNING. Computers are wonderful tools to assist us in our professional lives, but 
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only if we bring our intelligence to bear. The more skillful the user, the more powerful the impact 
of the computer on our professional and non-professional productivity.  

You practiced three important skills of database management in this tutorial: 
1. You learned how to search and query a database so that, no matter how large it might be, 

you could easily and quickly get the answers to any questions you might have. Getting 
answers to questions, research and so forth, is what creating electronic databases is all 
about. 

2. You learned how to sort a database, and select out subsets of records. 
3. You learned how to create and print new layouts or reports based on the data in a database. 

Perhaps you have already learned about the value of database management systems such as Access 
in the educational process. Databases are the electronic storage bins for knowledge. Today they 
are both local and global in scope. More and more data is becoming available for on-line research. 
In time, maybe 50 years from now, maybe less, all knowledge will be accessible electronically. In 
the meantime, as teachers we should become aware of just what is available to our students, and 
do what we can to educate them to take advantage of information services of all kinds. 

The role of teachers is changing. We are no longer the source of all knowledge. Rather, we are 
"knowledge brokers," intermediaries between our students and the source of the data they need so 
that they can "grow in wisdom and knowledge." As someone has observed, "Teachers should move 
away from being sages on the stage, and become, instead, the guides at the side." 

 

LOOKING FORWARD 
There is more to learn about the Access database. It is beyond the scope of this book to cover all 
of the features of the software. However you have certainly learned the fundamentals and have the 
tools now to make a database work for you and for your students. The exercises that follow in the 
SKILL CONSOLIDATION section will help you reinforce the knowledge you have gained. 

"Practice makes perfect" is as true of computer use as it is of any other skill-based activity like 
playing tennis or baking a cake. So is that other saying: "Use it, or lose it." You can probably 
identify many examples from your own experience where skills you were once proud to have 
mastered have become 'rusty' for lack of use. Likewise, you will quickly forget what you are 
learning in these tutorials unless you resolve to continue to apply the lessons learned on a regular 
basis, either for your own work or in the context of the classroom. 

The best teachers will use all the help they can get. The purpose of these tutorials continues to 
be to sharpen your skills in the use of one of the most powerful classroom tools yet devised—the 
electronic computer. You are to be congratulated for having persevered thus far. The remaining 
two tutorials will help you integrate the skills you have learned, and hopefully spur you on to a 
commitment to continue to incorporate the computer into your professional life both for your own 
sake and for that of your students. 

 

SKILL CONSOLIDATION 
Complete as many of these exercises as you can to reinforce what you learned in Lesson 8. 
1. Work with a group of your colleagues or classmates to specify and create a series of reports to 

accompany a database of student data such as the Roster Template database that you created 
in Lesson 6. Save the template with the set of reports. 
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2. From the Work Files for Office 2013 folder on your USB drive, open the Roster 2008 database 
onto the Desktop. 
• Add a record 
• Change the address and phone # in an existing field 
• Arrange the records chronologically on date of birth 

3. Create a new database (do not use a database you already created) on any topic of your 
choosing. 
• Design the fields (at least 10) to be included in the database 
• Save the empty database document 
• Add at least 20 records 
• Save the database document again 
• Prepare a report using just 5 of the fields in the database 
• Save the database with the report and send the database to your professor as an attachment 

in email 
4. Open the Birds database (in the Practice folder on your Work Disk) onto the Desktop. 

• Find all the birds that have blue, grey, green, or olive in their Color1 plumage 
• Arrange (Sort) the birds in descending order (reverse alphabetical order—from Z to A)—the 

Birds, not the Colors! 
• Prepare a report using just the following 5 fields in the database: Common Name, Family, 

Color1, Habitat, Count 
• Save the Birds database with the report and send the database to your professor as an 

attachment in email 


