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 [The following set of directions assumes that you are using 
Microsoft Office 2007. You may need to make minor adjustments 
if you are using an earlier version of Microsoft Office.] 
 
First things first 

This tutorial assumes you have Internet 
Explorer and Microsoft Office SharePoint 
Designer installed on your computer. 

It also assumes that you have successfully 
completed handout #1. 

It'll be easier for you if you close down all 
active programs (including IM!!) before 
continuing with this tutorial. 

Also, if you didn't already do so, create a new 
folder on your flash drive or other disk with the 
name Web Pages or some such name. Here’s 
how you create a new folder: 

Go to Start > My Computer 

Locate the disk or the place on your hard 
drive where you are going to create the new 
folder 

Right Click anywhere on the white space in 
the disk window and select New... > 
Folder, then give the new folder the name 
Web Pages 

This tutorial assumes that you have a picture 
saved on your disk and ready to use. It must be 
either a .jpg file or a .gif file and the name of the 
file must have NO spaces in it. The picture must 
be no larger than about 100K. 

You are not required to put a picture of yourself 
on your home page. But you must put some 
picture or other so that you can learn how to do 
this. Put a picture of one of your pets if you like, 
or of the countryside. 

So, make sure you have a .jpg or .gif picture no 
larger than about 100K saved on your disk (in 
your Web Pages folder) before you proceed 
with the tutorial.1 

                                                        
1 Handout #4, available for download from 
educationworld.com, explains how to reduce the size 
of pictures or other graphics. Modern cameras take 
pictures that are quite large in terms of byte-size, so 
you will usually need to resize them so that they are 
the appropriate size for use on the web. 

Step 1:  Opening your File Manager in 
SuperFreeHost 

First put your flash drive in the port so you can 
save the files you’re about to create. If you’re 
using your own computer, be sure to back them 
up on your hard drive, too. 

Open Internet Explorer. 

Now go to http://www.superfreehost.org and 
login with your login name and password (the 
one you set up using Handout #1). After a few 
seconds, you should now see a web page similar 
to the one illustrated below: 

 
In order to get yourself set up to work on your 
web pages, you need to open up a second 
window in your web browser (this is so that you 
will be easily able to go back and forth from 
your File Manager to your actual web page in 
order to check your work as you go along—
you’ll see how it works in a bit). 

Open up a second window in your web browser 
by pressing control-N (“N” for New Page). 

In this new, second window, locate your 
superfreehost home page URL--it'll look 
something like this (see circled item in 
illustration above): 

http://yourname.superfreehost.org/ 

(where “yourname” is your own login name!). 
Click on the URL to open up your home page in 
this second browser window. Don't worry about 
how it looks for now. It's just a default 
homepage that SuperFreeHost gives you when 
you first set up your website account. You're 
going to put your own info on your home page 
in Step 4. 
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Your screen should now look something like 
this: 

 
Notice above that there are two buttons in the 
Task Bar at the bottom of the screen—one for 
SuperFreeHost.org and the other indicating 
“Account Successful” for your Home page. 

In the Control Panel, click on File Manager. 

Now you are in your SuperFreeHost File 
Manager. There is only one document in there 
at the moment (called index.html). 

 
In a while you're going to replace this document 
with an index.html file of your own.  

Now, locate on your computer and open 
Microsoft Office SharePoint Designer. 

You’re ready to start work on your Web Pages 
Project! 

Step 2:  Creating a template file to use for all 
the pages in your website 

When you have completed Steps 2 and 3, your 
web page in SharePoint Designer will look 
something like the illustration at the top of the 
next column—only the background and font 
colors will be different: 

 
Look in the Task Bar at the bottom of the 
screen (where the Start button is). 

You should have 3 icons for open documents (or 
tasks). The first icon should be for your File 
Manager, the second icon is for your home 
page on the web, and the third icon is for 
Microsoft Office SharePoint Designer, which 
should be the active window right now. 

In Microsoft Office SharePoint Designer select 
File > New > Page > General Page. 

You’ll have a blank page on the screen. First, 
let’s tidy up the screen by removing all the 
menus on either side, EXCEPT the Tag 
Properties Task Pane. Click to X out of all the 
other Task Panes. 

Selecting a Background Color 
Next thing you want to do is select a color or 
pattern for the background for your 
webpage—which will be the same background 
on all your web pages. 

From the Format menu, select Background… 
and check out the different colors in the dialog 
box by clicking on the small arrows next to each 
Color category (Background, Text, Hyperlink, 
etc. 

This is the 
window in 
which you 

will be doing 
all the work 
on your web 

pages 

You will 
check out 
your work 

in this 
Window 
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Pick a color that looks attractive to you. Take 
your time. To see how each color will look, hit 
OK and check out your page. If you don't like 
how it looks, go back to the Format menu again 
and select Background … You can always 
change a background later, if you want, but it's 
best if you can find one you like at this stage. 

Selecting a Background Pattern 

If you want to use a pattern instead of a plain 
color, click to put a check mark in the box next 
to Background Picture (see figure below). You 
can find hundreds of patterns on the following 
website: 

http://www.squidfingers.com/patterns/1/ 

Selecting Colors for Text and Hyperlinks 

You may want some color other than the default 
Black for the regular text font on your web 
pages. You can do this in the Background dialog 
box, too. If you want to change the text color 
again later on, you can also go to the Font Color 
tool in the toolbar at the top of the window on 
the right and select a color you like. 

While you’re at it, in the Background… dialog 
box click on the Hyperlink colors (see 
illustration above) and select colors for the 
hyperlink, visited hyperlink, active hyperlink 
and hovered hyperlink that will stand out well 
against the background color or pattern you’ve 
chosen. 

For example, if your background is blue (which 
is not a bad background color if you like blue), 
make sure your text is, say, white, and each of 

the four hyperlink colors is a color which stands 
out well against a blue background. 

Another tip—avoid red or green on black or 
vice versa because these colors are very difficult 
for color-blind folks to distinguish between. 

Once you have made up your mind and chosen 
your background color or pattern, and the best 
colors for the hyperlinks, hit OK. 

You can have different background colors or 
patterns for different pages in your website, but 
for now it's best if you keep every page with the 
same look and feel—that’s why we’re going to 
call this first webpage Template.htm. 

Saving the Template.htm file 

So, go to File > Save As…, type the file name 
Template.htm, make sure you're saving it in the 
Web Pages folder on your disk, and then hit 
Save. 

Now you have to complete work on the 
Template.htm file. 

Completing the Template.htm file 

What you're going to do now is put in the 
Template.htm file certain features, such as a 
Navigation Bar and a Copyright statement, 
along with some horizontal lines, which will be 
COMMON to ALL the pages on your website. 
The purpose of creating a template web page is 
to save you having to create these features over 
and over again for the many web pages (about 
50) that you’re going to build over the course of 
this Web Pages Project. You'll see how it works 
in Steps 9 and 10. 

 

Step 3:  Add a Navigation Bar and Copyright 
line to your Template.htm file 

For the web project you’ll complete during the 
remainder of this project, you need to include a 
Navigation Bar at the top of every page. The 
Navigation Bar, which is designed to help your 
users get around your website, will include 6 
hyperlinks to various key pages in your 
website. Following are the steps to do this. 

If SharePoint Designer is not the active 
window on your screen--which it should be if 
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you're working through this tutorial in one 
sitting--click in the Task Bar on the icon to 
bring up the window for SharePoint Designer. 

The cursor should be positioned at the very top 
of the page. 

In the Formatting Toolbar, click on the Center 
align icon. 

Type the following with a space either side of 
the bar (where the bar ( | ) between each item is 
the shift-backslash key just below the 
Backspace key on the keyboard) Be careful to 
hold down the Shift key while you hit the 
backslash key, so that you get the upright bar (|), 
NOT the back slash (\) 

Home | Resume | Portfolio | CMS | Links | Roots 

Hit Enter. 

Now, from the Insert menu select HTML > 
Horizontal Line. 

Before proceeding, you need to undo the 
SharePoint Designer default of double spacing 
between lines. You want single line spacing for 
your web pages. So go to Edit > Select All (or 
press ctrl-A), then go to Format > Paragraph. 

 
In the Format > Paragraph dialog box (see 
figure above), locate the boxes for Spacing > 
Before and After, and type 0 (zero) in both of 
them, then select Single for the Line Spacing, 
then click OK. 

Save the Template.htm file again on your disk. 

Creating Hyperlinks for the Navigation Bar 
Items 

Next, double click on the first item in the 
Navigation Bar (Home), right click on the 
highlighted word and, from the pop up menu, 
select Hyperlink… 

In the dialog box that pops up, make sure the 
button on the left side for Existing Web Page is 
selected, then in the Address box type the URL 
(Universal Resource Locator): 

http://yourloginname.superfreehost.org/ 

and click OK. 

Now you're going to do the same thing for the 
next five items in the navigation bar, except that 
the URL you'll type each time will include a last 
item which will be the name of a web page 
you’ll be creating shortly. 

The URL for Resume will be: 

http://yourloginname.superfreehost.org/resu
me.pdf (all lower case, note the extension .pdf) 

The URL for Portfolio will be: 

http://yourloginname.superfreehost.org/portf
olio.htm (all lower case, note the different 
extension .htm for this and the following URLs) 

The URL for CMS will be: 

http://yourloginname.superfreehost.org/cms.
htm (all lower case, note that cms is 
lowercase!!) 

The URL for Links will be: 

http://yourloginname.superfreehost.org/links.
htm (all lower case) 

The URL for Roots will be: 

http://yourloginname.superfreehost.org/roots.
htm (all lower case) 

Save the Template.htm file again on your disk 
when you're done updating the hyperlinks. 

Remember, if your Hyperlinks are a color that 
doesn’t stand out well against the background 
you chose is Step 2, you can change any of the 
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colors by following the directions in Step 2 
(page 3 of this tutorial). 

Now all you have to do is add one more 
horizontal line and a Copyright line to your 
Template.htm file. Here are the steps to do this: 

Position the cursor on the new line beneath the 
horizontal line which you already inserted 
under the Navigation Bar. 

Hit Enter. 

From the Insert menu select Horizontal Line 
again, then in the Formatting Toolbar select 
the Left align icon. 

Go to Insert > Symbol…, and in the dialog box 
that pops up locate the copyright symbol (©), 
click on it, then click on Insert. 

Hit the space bar and type the following: 

Your name, 2009 (or whatever the year is when 
you complete this tutorial), all rights reserved / 
Revised month/day/year (where 
month/day/year is today’s date) 

Your Template.htm file is almost ready for use. 
But just in case (because SharePoint Designer 
can be odd in this regard), before you save it, hit 
ctrl-a, then go to Format > Paragraph and 
make sure everything is still single-spaced with 
0 (zero) spacing Before and After paragraphs. 

Once again, save the Template.htm file in the 
Web Pages folder on your disk. 

So, from now on, whenever you need to create a 
new page for your website, you’ll first open this 
template file and use it as the basic web page for 
the content that you will add on the new page. 

 

Step 4:  Setting up of your index.html file 
(your home page) 

OK, now you're ready to get to work on your 
home page.  

First--and VERY important--you need to 
rename the template by RE-saving it with a new 
name for the web page you're about to create. In 
this case, the new web page is your home page 
called index.html. 

So, right away, in SharePoint Designer go to 
File > Save As... and in the Save As dialog box 
change the file name from Template.htm to 
index.html, then (this is very important!) 
BEFORE you click on Save, click on the 
Change Title button and, in the dialog box that 
pops up, type the following: 

Your_Name’s Home Page 
Where Your Name is, of course, your own 
name. Now you can click on Save. 

Remember, if, before the end of this section 
(Step 4), you are asked to save your work, go 
ahead and do so, but be sure the file has the 
name index.html each time. 

Follow the directions carefully and, as you go 
along, type only what is in italics. Everything 
else consists of directions to help you complete 
the creation of your home page on the web. 

Also, everything below that is in square 
brackets […] will be particular to you, since it 
will be your personal info, so come up with your 
own data for those sections. 

Position the cursor on the empty line between 
the two horizontal lines beneath the Navigation 
Bar towards the top of the page. So you’re 
going to continue adding information below this 
first horizontal line and above the second 
horizontal line. 

Select the Center alignment icon, then type your 
first and last name, followed by apostrophe ‘s’, 
followed by the words Home Page. 

Hit Enter twice, then in the Formatting toolbar 
select Align/Left and type what follows: 

This is my homepage on the World Wide Web. I 
am a student at […]. This is my [???] year here. 
I will be graduating in [???] with a Bachelor of 
[???] Degree in [???].  

Hit Enter twice and type the following: 

Here are some of the classes I am taking now:  

Hit Enter, then from the Formatting toolbar 
select Bullets 

Type as many of your classes as you like (4 at 
least). Microsoft Office SharePoint Designer 
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will automatically provide the bullets based on 
your chosen theme.  

After you type your last class, hit Enter, then, in 
the formatting toolbar at the top of the window, 
click on the Bullets tool again to turn off the 
bullet at the beginning of the line. 

Now type the following: 

Here is a listing of some of the interests and 
hobbies I enjoy: 

Hit Enter, then from the Formatting toolbar 
select Bullets again, and type as many of your 
hobbies or interests as you like (4 at least). 
Microsoft Office SharePoint Designer will 
again automatically provide the bullets. 

After you have entered your interests, hit Enter, 
then hit the Backspace key to turn off the bullet 
at the beginning of the line. 

You'd better save your work before you go on, 
right? Hit ctrl-S. 

Now, from the Insert menu, select Horizontal 
line. Microsoft Office SharePoint Designer 
will insert a (third) horizontal line all the way 
across the page. 

Hit Enter again, click on the Center Align icon 
and type the following: 

E-mail me 

Hit Enter. Now drag to select the phrase e-mail 
me, click on the Insert Hyperlink button in the 
toolbar at the top of the screen (the icon looks 
like a globe) 

In the dialog box, click on the item on the lower 
left for E-mail Address and in the Address: 
box type: 

mailto:your_preferred_email_address 

(where your_preferred_email_address is your 
own e-mail address—say, hotmail or aol, if you 
have one you prefer to use). 

Hit Enter twice. Now type the following: 

Click here to visit Mr. Poole’s home page 

Hit Enter again and triple click to highlight the 
line you just typed, then click on the Insert 
Hyperlink button in the toolbar at the top of the 
screen. 

This time you are going to make the text a 
hyperlink to Mr. Poole’s home page. So, in the 
dialog box, click on the button on the left side 
for Existing File or Web Page. 

In the Address: box type the URL for my home 
page: http://www.pitt.edu/~poole and click 
OK. 

Now save the updated page again on your disk 
with the file name index.html. 

 

Step 5: Uploading pictures to your File 
Manager 

The directions in Steps 5 and 6 are critical, so be 
sure the follow them very carefully. 

You should already have saved on your 
computer the picture you are going to use on 
your home page. It should be no more than 
about 100K in size (see Handout #1), it should 
be either a .jpg or a .gif file type, and there 
should be NO spaces in the name of the picture 
file. 

It's best to have your pictures already uploaded 
to your SuperFreeHost File Manager before 
inserting them into a web page in SharePoint 
Designer. 

Here are the steps to upload the picture to your 
File Manager in SuperFreeHost. 

In the Task Bar, click on the first icon to bring 
up your File Manager on the screen. 

Locate, on the left hand side of the File 
Manager, the Upload Files button and click on 
it. 
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In the new dialog box, click on the first Browse 
button, then locate on your disk the picture you 
are going to use on your home page. Before you 
upload the file, however, write down on a piece 
of paper the exact name of the picture (upper 
and lowercase are important). You’ll need this 
later when you complete Step 6 of this tutorial. 

Now double click on the name of the picture. 
This will put it in the Browse box. 

 
Locate the Upload button, and click on it to 
upload your picture to your File Manager. 

Check the see that the file Uploaded successfully 
(you should now see the new file listed along 
with index.html in the list of files in your File 
Manager). 

 

Step 6: Inserting the picture into your web 
home page 

Now that you have the picture uploaded to your 
File Manager, you can Insert it into your home 
page in SharePoint Designer. 

In the Task Bar click on the icon for 
SharePoint Designer (should still be the third 
icon along). 

Put the cursor on a new line immediately 
under the Title at the top of the page (“My 
Name’s Home Page”), then go to Insert > 
Picture > From File…. 

Locate the picture on your computer or disk and 
double click on it to insert it into your web 
page. 

In the Accessibility Properties dialog box that 
pops up next, for Alternate Text type your own 
first and last name (this will make your name 
pop up on your home page when the user hovers 

the mouse over the picture). Leave the Long 
description empty. 

Don’t worry about the size of the picture for 
now; you'll take care of that in a bit. 
Immediately, right click on the picture, and 
select Picture Properties from the pop up 
menu. 

Click on the General Tab if it is not already 
selected and, in the Picture: box, remove all the 
text before the name of your picture (so only the 
name of your picture is in the box). Now, 
immediately before the name of your picture, 
type the URL of where to find the picture in 
your SuperFreeHost File Manager—it will look 
something like this: 

http://loginname.superfreehost.org/ 
So the whole URL will look like this when you 
are done: 
http://loginname.superfreehost.org/name_of_picture 

…where name_of_picture will be the picture 
file name that you just wrote down on a piece of 
paper. Remember that the name of the picture 
must be EXACTLY the same as the one you 
uploaded to your File Manager in Step 5, 
including uppercase or lowercase, etc. So, if 
your picture has .JPG instead of .jpg, you must 
type it like that. 

Click on OK and wait while the picture is 
uploaded from SuperFreeHost to your home 
page in SharePoint Designer. 

If the picture doesn’t upload correctly, check 
(and redo if necessary) each of the directions in 
Steps 5 and 6, because you probably did 
something incorrectly. 

Adjusting the size of your picture 
Now is the time to adjust the size of the picture, 
if you think that's necessary. To do this, click on 
the picture once to select it, locate one of the 
small black handles in a corner of the picture 
and, while holding down the Shift key, drag to 
make the picture whatever size you want 
(holding down the Shift key will ensure that the 
picture isn’t distorted). 

Then click on OK. 
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Now select Save As to save your updated web 
home page. Be sure to save it on your disk with 
the name index.html (as already explained, this 
top level file has to be called index.html 
because it’s your home page on the web). 

 

Step 7: Uploading your web home page to 
your File Manager 

This is basically the same thing you did to 
upload your picture in Step 5. 

In the Task Bar at the bottom of the screen, 
click on the first icon to bring up your 
SuperFreeHost File Manager. 

Locate on the left hand side of the File Manager 
the Upload Files button and click on it. 

Click on the first Browse button, and locate on 
your disk the index.html file you just saved. 
Double click on the name of the file 
(index.html) to put it in the Browse box. 

Locate the Upload button, and click on it to 
upload the file to your File Manager. Your 
version of index.html will automatically replace 
the version that came with your registration to 
SuperFreeHost. 

 

Step 8: Checking out your home page on the 
web 

In the Task Bar, click on the second icon to 
bring up your home page window on the screen 
(it's the original default SuperFreeHost web 
page when you first bring it up on your screen). 

Now hit Ctrl-R on the keyboard. You must do 
this (Ctrl-R) to refresh the screen in order to 
see any changes you have made to the web page. 

Now, all being well, you should see your very 
own personal home page on the screen, with 
your picture and all the data about yourself that 
you typed into the web page in SharePoint 
Designer. Neat, huh? 

If there is a problem, call your lab instructor 
over and he or she will help you fix it. 

 

Step 9:  Creating the dummy pages for your 
portfolio, and other Navigation Bar 
hyperlinks. 

In the Task bar, click on the icon to go back to 
SharePoint Designer. 

From the File menu select Open, and locate on 
your disk, and open, the Template.htm file. 

Position the cursor immediately beneath the first 
horizontal line that is under the Navigation 
Bar. 

Type the phrase: The List of Contents for my 
Professional Portfolio will go on this page… 

Now from the File menu select Save As… 
(NOT Save…) 

Replace the filename Template.htm with the 
new filename portfolio.htm (all lower case), 
then, BEFORE you hit the Save button, do the 
following: 

Click on the Change Title button and, in the 
dialog box that pops up, type the phrase: My 
Name’s Professional Portfolio (where, 
once again, My Name is your own name). 

Make sure you are saving the file in your 
Web Pages folder. 

Now click on Save, then Close the 
portfolio.htm page. 

Get the idea? You’ve just created a dummy page 
for your portfolio. You’ll provide the 
information for your professional portfolio later 
in the project. 

Let’s create a dummy page now for each of the 
three other pages you have hyperlinked in the 
Navigation Bar (cms.htm, links.htm, and 
roots.htm—the link to your resume will be 
handled differently, as you’ll see later). 

From the File menu select Open, locate on your 
disk, and open, the Template.htm file. 

Position the cursor immediately beneath the 
horizontal line that is under the Navigation 
Bar. 

Type the phrase: The List of Contents for my 
Class Management System (CMS) will go on 
this page… 
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Now from the File menu select Save As… (not 
Save…), replace Template.htm with the new 
filename cms.htm (all lowercase, remember), 
and, before you hit Save, click on the Change 
Title button and, in the dialog box that pops up, 
type the phrase: My Name’s Class 
Management System Website. 

Click on Save, then close (x out of) the cms.htm 
page. 

From the File menu again select Open, locate on 
your disk, and open, the Template.htm file. 

Position the cursor immediately beneath the 
horizontal line that is under the Navigation 
Bar. 

Type the phrase: The List of my Favorite 
Links will go on this page… 

Now from the File menu select Save As… (not 
Save…), replace Template.htm with the new 
filename links.htm, and, before you hit Save, 
click on the Change Title button and, in the 
dialog box that pops up, type the phrase: My 
Name’s Favorite Links. 

Click on Save, then close (x out of) the 
links.htm page. 

From the File menu once again select Open, 
locate on your disk, and open, the 
Template.htm file. 

Position the cursor immediately beneath the 
horizontal line that is under the Navigation 
Bar. 

Type the phrase: Information about my 
Family Roots will go on this page… 

Now from the File menu select Save As… (not 
Save…), replace Template.htm with the new 
filename roots.htm, and, before you hit Save, 
click on the Change Title button and, in the 
dialog box that pops up, type the phrase: My 
Name’s Family Roots. 

Click on Save, then close (x out of) the 
roots.htm page. 

Do you feel like you’re getting the hang of this 
yet? I hope so  

 

Step 10:  Uploading the new web pages to 
your File Manager 

Whenever you create a new web page or update 
a web page in SharePoint Designer, you have to 
Save it and then you must upload it to your File 
Manager so that you can view the page on the 
Web. If you don’t upload your new or edited 
web page, it’ll never appear on the Web! 

Here’s a reminder of the steps to upload a file to 
your File Manager. 

In the Task Bar at the bottom of the screen, 
click on the first icon next to the Start button 
(the one for your File Manager). This will open 
up the File Manager window on your screen. 

Look on the left side of the File Manager 
window. You should see a button that says 
Upload Files. Click on the Upload Files button. 
You'll now see data entry boxes with a Browse 
button next to them. 

Click on the first Browse button. You'll see a 
dialog box come up asking you to locate on your 
disk the file you want to upload to your File 
Manager. 

In the dialog box locate the disk drive on which 
you have your Web Pages folder, in which you 
have saved all those dummy files you just 
created. 

Double click on the portfolio.htm file, for 
example, to drop it in the first Browse box. 

Now do the same thing to put into the next two 
Browse boxes the cms.htm and links.htm files. 

Click on the Upload Files button, and wait 
while SuperFreeHost uploads the three files to 
your File Manager. 

When it is finished, you'll see the uploaded files 
in the list in your File Manager (in blue font). 
Now click on the hyperlink that says: Continue 
to File Manager. This will take you back to 
your File Manager. 

Repeat this process to upload your roots.htm 
file. 
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Step 11: Checking out your home page 
In the Task Bar, click the icon for your home 
page (it should be the second icon along, next to 
the icon for your File Manager) to bring your 
home page up on the screen. 

Now, hit Ctrl-R. This will Refresh your page 
from scratch and show you the changes you 
made. (If you don't do Ctrl-R, you may not see 
the changes because the browser may simply 
Refresh an earlier version of the page which it 
has saved in a place called Cache on your hard 
drive. Ctrl-R forces the browser to go to the 
original source for the web page. 

Check everything out to make sure you correctly 
completed all the steps from the beginning of 
this tutorial. This means checking every single 
one of the hyperlinks to make sure they work, 
including those in the Navigation Bar on your 
home page. 

Each hyperlink (except the link to your resume, 
which will be a broken or bad link for now) 
should go to the web page you designated for it 
when you defined the hyperlink: either to one of 
the pages associated with the Navigation Bar 
(except the resume link), or to Mr. Poole’s home 
page. 

Check your “e-mail me” link, too, to make sure 
it comes up with a dialog box for the user to 
send you an e-mail. 

Now all you have to do is build the rest of your 
website. That's for another day. The handouts 
explaining everything required will follow. 
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